Gordon P. Hemsley

Linguist by day. Web developer by night.

Do you use Ubiquity?

Posted by Gordon P. Hemsley on June 16, 2010

As you may or may not know, Ubiquity is officially “on hiatus”. That means that the official Mozilla Labs team is not currently working on it at the moment. Unfortunately, when they made that decision, the latest released version of Ubiquity (0.5.4) was not compatible with Firefox 3.6.

Luckily, community member Satyr Murky (satyr) decided to keep maintaining Ubiquity (all alone!) and was able to bring it to a state where it works in Firefox 3.6 and even the latest trunk builds off mozilla-central (mostly). Satyr also fixed a number of bugs that were present, beyond support for the latest versions of Firefox. Unfortunately, none of Satyr’s fixes have been made officially: Ubiquity has been wallowing in dev-only land in an Hg repository, downloadable only from a BitBucket attachment.

But now Ubiquity 0.5.5 is just about ready (see bug 528417), and I’d like to see it get released. Who’s with me?

Do you use Ubiquity? Which version? (The older 0.1.x line works fine on Firefox 3.6—did you downgrade your Ubiquity?) Did you know about the developmental version? (Your add-on updater didn’t tell you about it, after all.) Or were you too scared to install it? Let me know in the comments.

Advertisements

Leave a Reply

Please log in using one of these methods to post your comment:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

 
%d bloggers like this: